82 lines
1.7 KiB
Nix
82 lines
1.7 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
modulesPath,
|
||
...
|
||
}:
|
||
|
||
{
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [
|
||
"xhci_pci"
|
||
"thunderbolt"
|
||
"nvme"
|
||
"usbhid"
|
||
"usb_storage"
|
||
"sd_mod"
|
||
];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" = {
|
||
device = "zpool/nixos/root";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/12CE-A600";
|
||
fsType = "vfat";
|
||
options = [
|
||
"fmask=0022"
|
||
"dmask=0022"
|
||
];
|
||
};
|
||
|
||
fileSystems."/nix" = {
|
||
device = "zpool/nixos/nix";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
fileSystems."/home" = {
|
||
device = "zpool/data/home";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
fileSystems."/var" = {
|
||
device = "zpool/data/var";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
fileSystems."/var/lib" = {
|
||
device = "zpool/data/var/lib";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
fileSystems."/var/lib/microvms" = {
|
||
device = "zpool/data/var/lib/microvms";
|
||
fsType = "zfs";
|
||
options = [ "zfsutil" ];
|
||
};
|
||
|
||
swapDevices = [
|
||
{
|
||
device = "/dev/disk/by-partuuid/7e7d0e0b-90b7-465c-a022-089b38e0f16d";
|
||
randomEncryption = true;
|
||
}
|
||
];
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|